No list or site templates available in Silverlight create form

September 7, 2011

After a recent upgrade from SharePoint 2007 to SharePoint Server 2010 the client noticed when a new site was created it used the default SharePoint 2010 look and feel. This wasn’t an issue until they tried to create a list in this site when they found the Silverlight popup box was displayed but the available list templates was empty and instead the in progress icon was displayed.

I spent a considerable amount of time looking for any additional details in the event viewer and the ULS logs but there was no details on why this was happening. I suddenly remember I had a similar issue with setting the theme in a new SharePoint site after the upgrade. The error in that situation was the theme gallery hadn’t been properly created so I check and there was no solution gallery at the root of the site.

I then used the same solution as with the theme gallery error. I when to the root of the site and went to create a new list. In the create screen I then changed the URL and removed the feature section of the URL and changed the template ID, see below.

URL to create a custom list
http://sitename/_layouts/new.aspx?FeatureId={00bfea71-de22-43b2-a848-c05709900100}&ListTemplate=100

URL to create a solution gallery list
http://sitename/_layouts/new.aspx?ListTemplate=121

I set the name to be solutions and click create. This created a new solutions gallery under the catalogs section of the site. When I went back to my new SharePoint 2010 site and tried to create an new list I was presented with the available list templates.


%d bloggers like this: